We are investigating an issue
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted 9 days ago. May 13, 2019 - 17:22 CEST
Investigating
Our infrastructure provider are doing a maintenance
Posted 9 days ago. May 13, 2019 - 17:04 CEST
This incident affected: API and Admin.