Ongoing Maintenance
Incident Report for Timekit
Resolved
Maintenance is now complete.

Thank you for your patience!
Posted Oct 26, 2021 - 01:05 EDT
Monitoring
We're still performing ongoing maintenance and should be finished within another 20 minutes.

Thank you for your patience!
Posted Oct 26, 2021 - 01:02 EDT
This incident affected: API, Admin, Google Sync, Microsoft Sync, Infrastructure (Digital Ocean), CDN (AWS Cloudfront), and Workers (AWS SQS).