Increased response time
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 27, 2018 - 06:05 CEST
Investigating
We are seeing increased response time and are monitoring the situation. No services are affected
Posted over 1 year ago. Apr 27, 2018 - 00:57 CEST
This incident affected: API.