Planned Database Maintenance
Incident Report for Timekit
Resolved
Maintenance complete
Posted Jun 21, 2022 - 00:11 EDT
Investigating
Planned database upgrade during maintenance window
Posted Jun 21, 2022 - 00:01 EDT
This incident affected: API (API), Admin Portal (Admin), and Google Sync, Microsoft Sync.