Sign ups temporarily disabled
Incident Report for Timekit
Resolved
Issue has been resolved for now.
Posted Apr 12, 2022 - 14:41 EDT
Investigating
We are currently investigating a potential DDOS attack on Timekit and have temporarily disabled the signup endpoint. We'll communicate with an update when we have more info.
Posted Apr 12, 2022 - 14:06 EDT
This incident affected: API (API).