We are experiencing failing requests
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 23, 2019 - 22:07 CET
Monitoring
Our email provider is experiencing issues. They seem to be resolved but we are monitoring the situation closely.
Posted 7 months ago. Jan 23, 2019 - 21:04 CET
Investigating
We are currently investigating the issue!
Posted 7 months ago. Jan 23, 2019 - 20:50 CET
This incident affected: API.