Cannot view list of apps
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted May 30, 2020 - 14:50 EDT
Investigating
Chargify (Our billing provider) is having problems, we are waiting for them to fix the issue, check: https://status.chargify.io/
Posted May 30, 2020 - 13:55 EDT
This incident affected: Admin Portal (Admin).