Calendars Sync Delay
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 22:01 CEST
Monitoring
The queue is picking jobs up. Jobs are being run.
Posted Apr 19, 2021 - 21:50 CEST
Investigating
Calendar sync jobs are very slow causing delays in the synchronization between Google/Microsoft to Timekit.
Posted Apr 19, 2021 - 19:44 CEST
This incident affected: Google Sync and Microsoft Sync.