Infrastructure maintenance
Incident Report for Timekit
Resolved
Our API servers are currently undergoing maintenance for the Meltdown and Spectre vulnerabilities. Please see the Digital Ocean ticket for further information. See: http://status.digitalocean.com/incidents/pyc5z21fk5kr

They should be up again in no time. We're super sorry for the inconvenience!

--------------------------

Update:
The maintenance window went on for 15 minutes with intermittent downtime between 4:16 - 4:32 PM UTC. All servers have been updated and rebooted now, all back on track.
Posted Apr 03, 2018 - 18:37 CEST