Stability issues, problems with Google sync
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 18:34 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 26, 2020 - 22:59 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2020 - 19:20 CET
Investigating
We are currently investigating this issue.
Posted Feb 26, 2020 - 16:46 CET
This incident affected: API, Admin, Google Sync, and Microsoft Sync.