Google Calendars not syncing
Incident Report for Timekit
Resolved
The Google synchronization backlog is now catching up, we expect all calendars to be caught up over the course of the next few hours
Posted Jun 22, 2021 - 18:49 CEST
Identified
Cause has calendar syncing issue has been identified and we're working on deploying a fix.
Posted Jun 22, 2021 - 16:39 CEST
Investigating
A number of resources calendars have stopped receiving update notifications from Google Calendar regarding calendar updates. This results in resources not automatically synchronizing with Timekit. Not all resources are affected.

As a temporary workaround, go-forward synchronization is fixed after a single manual sync triggered by pressing "Sync Now" in the Timekit Admin portal under Resources->User Settings->Calendar Sync. Users who need an immediate fix should click on this button to resolve the issue for all their resources.

We are currently working on an automatic solution to reset synchronization with Google for all accounts that are having this issue and will post updates when the work is complete.
Posted Jun 22, 2021 - 15:51 CEST
This incident affected: Google Sync.