Abnormally high load
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 13:48 EST
Investigating
We are experiencing abnormally high load and are working to address the issue
Posted Feb 25, 2021 - 12:13 EST
This incident affected: API (API).