The API and Admin page are experiencing issues
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted Nov 02, 2021 - 12:06 EDT
Investigating
Hello Everyone,

We're currently experiencing issues with our API and Admin page. Please rest assured that the support team is aware of the issue and we're currently looking to resolve it.

Please check out the status page for further updates.
Posted Nov 02, 2021 - 11:21 EDT
This incident affected: API and Admin.