Server Maintenance
Incident Report for Timekit
Resolved
Maintenance is completed, back to normal again 👍
Posted 11 months ago. Sep 20, 2018 - 14:31 CEST
Identified
Our DB servers at Digital Ocean are currently undergoing maintenance. Expect intermittent connection issues, but the service should to be stable again soon. Stay tuned.

Follow the status here:
http://status.digitalocean.com/incidents/r66k686k87nw
Posted 11 months ago. Sep 20, 2018 - 11:57 CEST
This incident affected: API, Admin, and Infrastructure (Digital Ocean).