Service DB down
Incident Report for Timekit
Resolved
The problem has been solved and we are back to normal. We apologize for the inconveniences this have caused!
Posted 9 months ago. Nov 16, 2018 - 09:57 CET
Identified
We're experiencing an incident that affects our whole service. Actively investigating and working on a imminent fix!
Posted 9 months ago. Nov 16, 2018 - 09:30 CET
This incident affected: API, Admin, Google Sync, and Microsoft Sync.