SSL Certificate Renewal
Incident Report for Timekit
Resolved
The SSL certificate issue has been resolved and Timekit is back to operational status.

Thank you for your patience and understanding!
Posted Jul 12, 2021 - 08:16 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2021 - 07:31 EDT
Investigating
Hello All,

The API and Admin page are inaccessible at the moment. This is due to an SSL certificate that needs to be renewed. We are in the process of rectifying it right now.

Updates will appear here.

Thank you for your understanding
Posted Jul 12, 2021 - 07:29 EDT
This incident affected: API (API) and Admin Portal (Admin).