TimeKit API and Admin are experiencing slowness
Incident Report for Timekit
Resolved
The queue has cleared, incident is resolved
Posted Jun 03, 2021 - 17:12 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2021 - 16:01 EDT
Identified
The issue has been identified, and the queue is being cleared now. We estimate it'll take ~3 hours to clear the queue.
Posted Jun 03, 2021 - 16:01 EDT
Update
We are still investigating the sync issues with Google and Microsoft calendars. We thank you for your patience.
Posted Jun 03, 2021 - 13:48 EDT
Update
We are still investigating the sync issues with Google and Microsoft calendars
Posted Jun 03, 2021 - 12:30 EDT
Update
We're experiencing problems synchronizing Google and Microsoft calendars
Posted Jun 03, 2021 - 11:11 EDT
Update
We are continuing to investigate this issue.
Posted Jun 03, 2021 - 11:01 EDT
Update
API and Admin has been restored but experiencing degraded service
Posted Jun 03, 2021 - 10:22 EDT
Investigating
We are currently investigating this issue.
Posted Jun 03, 2021 - 10:22 EDT
This incident affected: API (API), Admin Portal (Admin), and Google Sync, Microsoft Sync.