API is partly down due to DB migration
Incident Report for Timekit
Resolved
This incident has been resolved.
Posted Jan 23, 2017 - 19:20 CET
Investigating
A DB migration is taking longer than expected. Investigating!
Posted Jan 23, 2017 - 14:43 CET