Admin page decreased functionality
Incident Report for Timekit
Resolved
We've been advised that our third party has mitigated the effects of the problem and
Posted Apr 14, 2022 - 09:17 EDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2022 - 08:51 EDT
Investigating
Admin page connectivity is experiencing a problem due to a third party outage
Posted Apr 14, 2022 - 08:35 EDT
This incident affected: Admin Portal (Admin).